WinAsm Studio, The Assembly IDE - Free Downloads, Source Code
Sponsors
Articles
Programming Quick Start
32-bit Assembler is Easy
Porting Iczelion tutorials
What is FASM
What is FASM G
Hard Drive Recovery
Wiring your own LAN
Personal menu
Welcome Guest
User:
Pass:
Register!
Resend Validation Email
 
Forum
 

Bug report under Windows Vista Family Premium, WinAsm Studio 5.1.8.0 crashed twice tonight

laledesi
Quote Post


Very Active Member
****

Group: Members
Posts: 78
Member No.: 787
Joined: 16-November 04


Sponsored Links
It still runs very well for more than 99% of the time, though, but the OS shuts it down sometimes (not the first time it happened but maybe by reporting these crashes, they might be corrected in a future release). Here it goes:

OS#: Windows 6.0 (with all up-to-date Windows Update patches) Family Premium Edition

Processor: AMD Turion 64 X2 Mobile Technology (2 CPUs) ~1.6 GHz

RAM: 1918 MB (almost 2 GB).

First crash happened after I closed the Recent Projects Manager dialog box where I just removed 3 recent projects in it, clicked the Apply button, then the Exit button, and went to click on the Close button at the top-right corner to exit WinAsm Studio. I click the Exit X button too fast, perhaps, but the GP-fault message box appeared saying WinAsm perfomed an unauthorized access and proposed to: Terminate, Report (to MS), or Debug it (I chose Terminate).

Second crash happened when browsing in Windows Explorer to create a new folder, and after clicking on the WinAsm Studio button in the Task Bar just to switch back to it, the same GP-fault poped-up. Maybe in WM_SETFOCUS (?).

If it happens again, I'll post here.

Keep it up.
PMEmail Poster
Top
XeS
Quote Post


Extremely Active Member
******

Group: Members
Posts: 253
Member No.: 15879
Joined: 3-December 08


Hi laledesi!
I've tried to reproduce it but can't find any problem. For your problem I also reaktivated the bug report service! Because I've disabled such an annoying service. I wouldn't get an error for both bugs you mentioned. Maybe you can be more clearly or the bug only exists in WinVista Premium edition.


-My Configuration-

Operating system:
  • Operating System: Microsoft Windows Vista Business
  • OS Kerneltyp: Multiprocessor Free (32-bit)
  • OS Service Pack: Service Pack 1
  • OS Version: 6.0.6001 (Vista Retail)
  • DirectX: DirectX 10.0
Motherboard:
  • CPU Typ: QuadCore Intel Core 2 Quad Q6600, 2400 MHz (9 x 267)
  • Motherboard Name: Abit IP35-E (3 PCI, 2 PCI-E x1, 1 PCI-E x16, 4 DDR2
  • DIMM, Audio, Gigabit LAN)
  • Motherboard Chip: Intel Bearlake P35
  • Internal Memory: 3328 MB (DDR2-800 DDR2 SDRAM)
  • 3* DIMM1: OCZ XTC Platinum OCZ2P8002G 2 GB DDR2-800 DDR2 SDRAM
  • (6-6-6-18 @ 400 MHz) (5-5-5-15 @ 333 MHz) (4-4-4-12 @ 266 MHz)
Display:
  • Videocard: NVIDIA GeForce 8800 GTS (640 MB)
All drivers are up to date!

Attached file shows my service configuration! (german!)
-"Gestarted" = "running"
-"Deaktiviert" = "deactivated"

Bug Report Service (or something similar) -> "Windows-Fehlerberichterstattungsdienst"

Don't apply the whole list to your services! Because I don't need some services, but maybe you need them.

[WIN]+[R]
insert "services.msc" and hit enter to see your service-configuration.

Regards,

XeS

Attached File ( Number of downloads: 4 )
 Login or Register to download
PMEmail PosterUsers WebsiteICQ
Top
laledesi
Quote Post


Very Active Member
****

Group: Members
Posts: 78
Member No.: 787
Joined: 16-November 04


Thanks Xes.

These crashes did not cause any damage since they happened while there was no projects loaded in WinAsm at the time, so I lost no unsaved code lines.

If WinAsm 5.1.8.0 crashes again (it happened once last week also, and in about the same circumstances), I'll try to report it here with more details, if I can get more details about it, so it could be easier to fix.

Back to coding. )(
PMEmail Poster
Top
laledesi
Quote Post


Very Active Member
****

Group: Members
Posts: 78
Member No.: 787
Joined: 16-November 04


Reporting another crash today just after I removed a project from the Recent Projects dialog and clicked on the Exit button.

From the GP fault message box extra information pane, it looks like the GP fault comes from the inside of the comctl32.dll system file installed on my (Fr) version of Windoze!?!

Here's a C&P from that GP fault pane:

Nom d’événement de problème: APPCRASH
Nom de l’application: WinAsm.exe
Version de l’application: 5.1.8.0
Horodatage de l'application: 49c35033
Nom du module par défaut: comctl32.dll
Version du module par défaut: 6.10.6000.16386
Horodateur du module par défaut: 4549bd09
Code de l’exception: c0000005
Décalage de l’exception: 00065837
Version du système: 6.0.6000.2.0.0.768.3
Identificateur de paramètres régionaux: 3084
Information supplémentaire n° 1: 8d13
Information supplémentaire n° 2: cdca9b1d21d12b77d84f02df48e34311
Information supplémentaire n° 3: 8d13
Information supplémentaire n° 4: cdca9b1d21d12b77d84f02df48e34311

I tried to find the meaning of this exception code (c0000005) but perhaps I didn't search at the right place. <_<
PMEmail Poster
Top
laledesi
Quote Post


Very Active Member
****

Group: Members
Posts: 78
Member No.: 787
Joined: 16-November 04


QUOTE
...comCtl32.dll tries to modify the resources for the pages. Because the resources are typically in read-only sections, this throws a first-chance exception that will be caught by the operating system. The operating system handles this exception and makes the resources writeable and then everything completes normally. Because the resources are now writeable, all subsequent calls complete without this first-chance exception

RESOLUTION

The first-chance exception can be ignored because it is safely handled by the operating system.

To prevent the exception, use one of the following methods:

    * Method 1: Make the resources read/write. You can do this by adding a linker setting as follows:

      /SECTION:.rsrc,rw

    * Method 2: Change the font of the pages so they are not MS Sans Serif. MFC checks the dialog template font for the page. If it is not MS Sans Serif, MFC makes a copy of the resource in read/write memory, and then modifies the font and passes this to the ComCtl32.dll. When the DLL writes to the template for the page, it is writing to read/write memory. Therfore, an exception is not thrown.

    * Method 3: Do not have the call for creating the property sheet in a try/catch(...) block. Instead, catch particular exceptions in the catch block.

If the property sheet is part of an OLE Automation Server that can be invoked through a method of the server, make the resources read/write by using one of the first two methods because OLE catches the exception.

Note When you change the resources to Read/Write, the resources might be written to a page file.


On edit:

I just read an 'article' about perhaps the PATH string of (many of) my projects are longer than 255 characters, which could 'explain' why the crashes do not *always* happen each time I remove a project from the Recent Projects dialog box. It could be the cause.

Another one says it could be because of a *very, very bad hard drive* in there!

So... which is which? :lol:
PMEmail Poster
Top
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll

 

Sponsors
Computer Science

Internet
C/C++
Hardware & PC maintenance

HiEditor

General Discussions
Suggestions/Bug Reports
WinAsm Studio

General Discussions
Suggestions/Bug Reports
WinAsm Studio FAQ
Multilingual User Interface
Add-Ins
Assembly Programming

Main
Newbies
Projects
Custom Controls
Snippets
Announcements & Rules

Announcements

General

Online Degrees - Distance Learning
The Heap
Russian
Google